Delays in group counts updating

Incident Report for PDQ

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 18:49 EST

Monitoring

All group changing queues, have caught up. Monitoring to make sure issue is fully resolved.
Posted Nov 03, 2025 - 14:43 EST

Investigating

We are currently investigating an issue with group count updates being delayed.
Posted Nov 03, 2025 - 12:12 EST
This incident affected: Connect (Device Scans).