Connect devices list not fully loading in some instances

Incident Report for PDQ

Resolved

This is fixed. Any customer still seeing the wrong number of devices on the All Devices page should simply refresh the browser page.
Posted Nov 14, 2025 - 18:15 EST

Update

Correction to earlier post - no issues have been reported with the reporting page.
Posted Nov 14, 2025 - 16:44 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 14, 2025 - 16:42 EST

Investigating

We're investigating reports today where a customer has clicked on the All Devices page and the list only partially loads.
Posted Nov 14, 2025 - 16:33 EST
This incident affected: Connect (Device Scans, Reports).