SimpleMDM Service Performance Degraded

Incident Report for PDQ

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 17:30 EDT

Monitoring

Observed performance degradation of the SimpleMDM service. This may have caused delayed delivery of profile and app installations and intermittent enrollment errors. A resolution has been identified and implemented, but we are continuing to monitor.
Posted Sep 25, 2025 - 11:30 EDT
This incident affected: SimpleMDM (App Licensing and Distribution, Configuration Profile Distribution, Apple Business Manager Device Assignment Sync (DEP)).