Verification emails not being received for anyone with Outlook

Incident Report for PDQ

Resolved

Our email provider is reporting that the incident is fully resolved.
Posted Feb 02, 2026 - 10:40 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2026 - 11:10 EST

Investigating

We are having lingering issues related to yesterday's M365 outage. Some verification emails are still not being delivered for those using Outlook/Exchange/M365.
Posted Jan 23, 2026 - 11:06 EST
This incident affected: Auth.