Connect: Some customers may be experiencing a delay in viewing updates

Incident Report for PDQ

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 18:55 EDT

Investigating

Some customers may experience a 4-8 minute delay in viewing updates in Connect. The changes are being registered immediately, but are not visible in Connect during that delay timeframe. We are currently troubleshooting the issue.
Posted Aug 05, 2025 - 18:36 EDT
This incident affected: Connect (Automations, Deployments, Device Scans, Package Library, Remote Desktop, Reports, Vulnerability Management, Web Admin).