Verification emails not being received for anyone with Outlook

Incident Report for PDQ

Resolved

Microsoft reports that this issue has been resolved.
Posted Jan 23, 2026 - 09:06 EST

Update

Update: this appears to affect anyone who uses Outlook.
https://status.cloud.microsoft/
Posted Jan 22, 2026 - 16:07 EST

Identified

Verification emails are not being sent. Correction: verification emails are being sent, but anyone with Outlook will not receive them. See https://status.cloud.microsoft/m365/
Posted Jan 22, 2026 - 16:04 EST
This incident affected: Auth.