Delays on gathering device information

Incident Report for PDQ

Resolved

After monitoring we are not seeing any more delays
Posted Dec 15, 2025 - 17:04 EST

Monitoring

Delays are no longer happening, and we are monitoring to make sure all items are resolved
Posted Dec 15, 2025 - 14:10 EST

Investigating

We are currently investigating delays on device information such as online/offline device info, scans, and deployment information.
Posted Dec 15, 2025 - 13:19 EST
This incident affected: Connect (Deployments, Device Scans).