Connect - Deployment slowdown observed

Incident Report for PDQ

Resolved

Queues have all caught up and deployments are operational.
Posted Feb 12, 2026 - 14:05 EST

Identified

We have resolved the issues causing backed up processing queues for deployments. There is still some backlog in the queues being worked through, but impacted users should start seeing improvements soon as these queues drain.
Posted Feb 12, 2026 - 12:51 EST

Investigating

We are investigating an issue with reported slowdown of deployments in Connect.
Posted Feb 12, 2026 - 12:02 EST
This incident affected: Connect (Deployments).