Connect: Ctrl + Alt + Del is not working in Remote Desktop

Incident Report for PDQ

Resolved

If "Secure Attention Sequence" is enabled in Group Policy, it must be set to "Ease of Access applications" in order for Connect to simulate "Ctrl + Alt + Del"
Posted Aug 27, 2026 - 21:08 EDT

Investigating

We are currently investigating this issue.
Posted Aug 27, 2026 - 19:15 EDT
This incident affected: Connect (Remote Desktop).