Connect: deployments not showing in the all deployments view

Incident Report for PDQ

Resolved

We've determined that deployments are indeed running and that this is a UI bug. We're going to address this issue during normal business hours on Monday.
Posted Jan 23, 2026 - 11:10 EST

Investigating

We're receiving reports from multiple customers that deployments are missing in the all deployments view yet visible for devices.
Posted Jan 23, 2026 - 10:27 EST
This incident affected: Connect (Deployments).