Due to AWS issues some users are reporting issues related to TOTP and MFA

Incident Report for PDQ

Resolved

Performance has gone back to normal
Posted Oct 20, 2025 - 18:12 EDT

Monitoring

We are seeing sparatic issues specifcally when sending sms codes. We are currently monitory and let you know when its resolved.
Posted Oct 20, 2025 - 14:11 EDT
This incident affected: Auth.