Delay in Group Recounts

Incident Report for PDQ

Resolved

All delays have now caught up and group counts are up to date.
Posted Apr 09, 2026 - 17:00 EDT

Investigating

After monitoring the implemented fix we determined the issue is still occurring and are back to investigating the issue. Group count updates are delayed.
Posted Apr 09, 2026 - 15:39 EDT

Monitoring

A fix has been implemented. Group recounts are still behind, but catching up. We are monitoring the fix to make sure the groups continue to update counts.
Posted Apr 09, 2026 - 15:16 EDT

Update

We are continuing to investigate the issue.
Posted Apr 09, 2026 - 14:02 EDT

Investigating

We are currently investigating an issue with a delay in group count calculations. With group count delays automations triggered off groups will be delayed.
Posted Apr 09, 2026 - 13:02 EDT
This incident affected: Connect (Automations).