Detect Degraded Performance

Incident Report for PDQ

Resolved

Detect performance in the front-end and platform have been resolved.
Posted Sep 08, 2025 - 17:05 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 08, 2025 - 10:11 EDT

Update

We are continuing to investigate this issue.
Posted Sep 08, 2025 - 04:25 EDT

Investigating

Detect is experiencing slow API response times.
Posted Sep 08, 2025 - 04:01 EDT
This incident affected: Detect (Detect).