Custom scans are delayed

Incident Report for PDQ

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 15:33 EDT

Investigating

Custom scans are delayed.
Posted Oct 29, 2025 - 12:34 EDT
This incident affected: Connect (Device Scans).