All SmartDeploy services unavailable due to Cloudflare outage

Incident Report for PDQ

Resolved

Services are fully operational at this time.
Posted Nov 18, 2025 - 12:52 EST

Monitoring

Cloudflare has reported a fix for their outage, and services seem online and stable. We will continue monitoring to ensure stability.
Posted Nov 18, 2025 - 10:40 EST

Update

Cloudflare has reported a fix for their outage, and services seem online and stable. We will continue monitoring to ensure stability.
Posted Nov 18, 2025 - 10:39 EST

Update

All APIs and service URLs are impacted as of this time.
Posted Nov 18, 2025 - 08:45 EST

Investigating

https://www.smartdeploy.com may be unavailable in some regions due to the ongoing Cloudflare outage.
Posted Nov 18, 2025 - 08:21 EST
This incident affected: SmartDeploy.