Detect: Agent's scanning data processing slow down

Incident Report for PDQ

Resolved

This incident has been resolved. Queues are continuing to clear, some residual delays in Detect scans are expected while queues catch up.
Posted Sep 26, 2025 - 13:48 EDT

Update

We’ve made progress in addressing the issue. While data from Agents is still being processed more slowly than expected, we are already seeing improvements in performance and a reduction in queues.

Our engineering team continues to actively work on fully resolving the issue, and we will provide the next update within 24 hours.
Posted Sep 26, 2025 - 03:48 EDT

Investigating

We’re currently investigating an issue where data from Agents is being processed more slowly than expected, due to a high volume of messages queued for our workers. The platform remains accessible, though some agent updates may be delayed. Our team is actively working to address the cause.
Posted Sep 25, 2025 - 10:20 EDT
This incident affected: Detect (Detect).